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Objectives 
 
In Four-Axis-Lesson-3 you will generate the toolpaths to machine the part on a CNC vertical 
milling machine with four-axis capability.  The outside diameters have already been completed. 
 
The part will be held in a rotary indexer as shown below.  These types of indexes can utilise 
collets or a three-jaw chuck.  This Lesson covers the following topics: 
 
 Open an existing file containing: 
The solid geometry for the part 
 
 Establish Stock Setup settings: 
Use a supplied StereoLithography (STL) file for 
toolpath verification 
Material for the part 
Feed calculation 
 
 
 Generate milling toolpath consisting of: 
Using the View Manager 
Using Views, Levels, Tool Planes and Construction Planes 
Create Contour, Pocket and Drill toolpaths 
Using Toolpath Transform to rotate toolpaths 
 
 Inspect the toolpath using Mastercam’s Verify and Backplot by: 
Launching the Verify function to machine the part on the screen 
Generating the NC- code 
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FOUR-AXIS-LESSON- 3 DRAWING 
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TOOL LIST 
 Two cutters will be used to create this part.   
 0.75 diameter flat end mill  
 0.25 diameter flat end mill  
 

FOUR-AXIS-LESSON-3 - THE PROCESS 

 

TASK 1:  Setting the environment 
TASK 2:  Introduction - Watch the video 
TASK 3:  Open an existing file 
TASK 4:  Identify the entities on each level 
TASK 5:  Machine the first face of the hexagon 
TASK 6:  Machine remaining faces of hexagon using Transform Toolpath 
TASK 7:  Machine the first face of the square 
TASK 8:  Machine remaining faces of square using Transform Toolpath 
TASK 9: Machine Pocket on BACK face 
TASK 10: Machine Open Pocket on BOTTOM face 
TASK 11:  Machine Pocket on TOP face 
TASK 12:  Drill holes on FRONT face 
TASK 13:  Drill hole on Hexagon at front 
TASK 14:  Drill hole on Hexagon at back using Transform Toolpath 
TASK 15:  Verify toolpaths using a supplied STL file 
TASK 16:  Post and create the CNC code file   
 

                  

 

 Getting Started 
Before working through these lessons you may find it useful to review the material in the Tips 
and Techniques section of the multimedia DVD that came with this text covering Work 
Coordinate Systems (WCS). 
 
 
If you are using the Online Course content the Work Coordinate Systems (WCS ) material is in 
the Tips and Techniques section of the main menu. 
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TASK 1:  
SETTING THE ENVIRONMENT 
Before starting the geometry creation you should set up the grid, toolbars and machine type as 
outlined in the Setting the environment section at the beginning of this text: 
1. Set up the Grid: Size= 1.0, X & Y Spacing= 0.25.  This will help identify the location of the 

origin. 
2. Customize the toolbars to machine a 4-5 Axis part. 

 
TASK 2: INTRODUCTION – WATCH THE VIDEO 
1. Before you start to work on this Lesson review the Introduction video on the multimedia DVD 

that came with this text.  You will find the video in the “Four-Axis-Lesson-3” section, it is 
entitled Introduction - 2 Minutes.  If you are using the Online Course content the video is 
available in this Lesson on the online content screen. 

 The video will review the techniques that will be used to generate the toolpaths utilizing the 
indexing table. 

    
   

 

TASK 3: 
OPEN AN EXISTING FILE 
 If you are using a Training Guide to go through this Lesson the required file is on the 

multimedia DVD that came with this text in a folder called Mastercam Files. If you are 
using the Online Course content the file is available in this Lesson on the online 
content screen.  The part is already setup for a: GENERIC HAAS 4 AXIS MILL. 

 
1. Select File>Open> Four-Axis-Lesson-3.  File is shown below in shaded view. 
2. Select File>Save as… 
3. In the File name box, type Four-Axis-Lesson-3.  
4. Save to an appropriate location. 

5. Select the green check mark button  to save the file and complete this function. 
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TASK 4: 
IDENTIFY THE ENTITIES ON EACH LEVEL 
 Before you start to work on the toolpaths lets first identify the entities on each Level. 
 

 Levels are a primary organizational tool in Mastercam. A Mastercam file can contain 
separate levels for wireframe, surfaces, drafting entities, and toolpaths.  

 By organizing your files into levels, you can more easily control which areas of the drawing 
are visible at any time and which parts are selectable so that you do not inadvertently make 
changes to areas of the drawing you do not want to change. 

 

1. Activate a shaded view by selecting the icon at the top of the screen. . 
2. From the Status bar at the bottom of the screen select Level.  
 The Level Manager dialog window will now appear. 
 As you can see in the picture below there are four Levels in this part.   
 Level 1 contains the Part geometry 
 Level 2 contains the Text, TOP, BOTTOM, BACK and FRONT.  This is on the part to help 

you with the orientation of the part as you work through creating the toolpaths 
 Level 3 contains the Curves that were previously created for the STL file geometry 
 Level 4 contains the Solid geometry that was previously created for the STL file 

geometry 
 Level 1 and 2 are visible as noted by the X in the Visible column.  
 
3. Turn off Make main level always visible as shown below. 
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4. Now make visible only Level 4 SOLID-STL.  Click in the Visible column for the various 
Levels so that the only X that appears is in the Visible column for Level 4. 

 
  

5. Select the OK button  to exit the Level Manager dialog box.  On the screen is the 
Solid Extrude used to for the STL file.  This STL file will be used to verify the toolpaths. 

 
 

6. From the Status bar at the bottom of the screen select Level.  
7. Now make visible only Level 3 CURVES-STL.  Click in the Visible column for the various 

Levels so that the only X that appears is in the Visible column for Level 3. 
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8. Select the OK button  to exit the Level Manager dialog box.  There are only two circles 
on this level.  These two circles were used to create the Solid Extrude used to for the STL 
file. 

 
 
9. From the Status bar at the bottom of the screen select Level.  
10. Now make visible only Level 1 and 2.  Click in the Visible column for the various Levels so 

that the only X that appears is in the Visible column for Level 1 and 2. Set remaining options 
and values as shown below. 

 
 

11. Select the OK button  to exit the Level Manager dialog box. 
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TASK 5: 
MACHINE THE FIRST FACE OF THE HEXAGON 
 In this task you will use the 0.75” diameter flat end mill to rough and finish the first face of 

the hexagon using Toolpath> Contour.  In the next task you will use Toolpath>Transform to 
machine the remaining faces of the hexagon. 

 

1. Set the graphics view to Isometric View.  

2. Select the Screen Fit icon found at the top of the screen to fit the part to the screen . 

 

Note  
At the bottom of the graphics 
screen the status of the Tool and 
Construction plane is set to TOP.  

 
3. Now dynamically rotate the display similar to the display shown below. The text TOP is 

facing up. 

 

Tool plane (Tplane)  
For most typical toolpaths, this is 
the plane in which cutting moves 
(G1/G2/G3) take place.  
 
The tool typically approaches and 
retracts from the part normal to 
the tool plane in the Z axis.  
 
You can align the Tplane with any 
of the standard planes or a 
custom orientation.  
 

4. Activate a wireframe view by selecting the icon at the top of the screen. . 
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5. From the menu bar select Toolpaths>Contour… 
6. When prompted to Enter new NC name ensure FOUR-AXIS-LESSON-3 is displayed and 

then select the OK button . 
7. On the screen you will now see the Chaining dialog box.  Select Single chain. 

 

Single 
Creates a chain out of a single line, arc, or spline.  
 

 
8. On the graphics screen is now a prompt to Select contour chain 1. Zoom in as required 

and select the single line shown below: 
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9. After selecting the line your graphics screen should look like the screenshot below, with the 

green arrow pointing left.  If the arrow is not pointing to the left select the arrow  from 
the Chaining dialog box to reverse the direction. 

  
   

10. After the contour has been successfully chained select the OK button  at the bottom of 
the Chaining dialog box. 

11. Ensure the Toolpath Type is set to Contour. 
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12. On the left of the dialog box select Tool.  Click on the Select library tool button and choose 
a 3/4” Flat End Mill.  Make changes to this page as shown below: 

 
 
13. Select Cut Parameters from the list on the left and make changes to this page if required. 
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14. Depth Cuts should not be activated. 

 
 
15. Select Lead In/Out from the list on the left and make changes to this page as shown below: 

 
 
16. Break Through should not be activated. 
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17. Select Multi Passes from the list on the left and ensure Multi Passes are activated by 
clicking on the small Multi Passes box.   Make changes to this page as shown below: 

 
 
18. Select Linking Parameters.  Input the depth of 0 and the other values as shown below: 
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19. Scroll down the list on the left and select Planes(WCS).  Set the Work offset to Zero.   

 

Work Offset # 
Assigns a work 
offset code to the 
view. When you 
use the view for a 
Tplane and create 
a toolpath. 
 
Mastercam will 
automatically 
output the work 
offset when you 
post the operation. 
Number the offsets 
sequentially from 
zero, or enter –1 to 
not assign any 
offset to the view.  

 

Work Offset # Setting this value to Zero will out a G54 in the CNC code file. 

 
 
20. When confronted with the Update View dialog box activate Update just this operation 

without changing the view. 

 
 

21. Click on the OK button when done . 
22. Select Coolant from the list on the left.  Open up the drop down menu for Flood and set it to 

On. 

23. Select the OK button  to exit Contour parameters. 
24. Save your Mastercam file. 
25. Backplot this toolpath. 
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TASK 6:   
MACHINE REMAINING FACES OF HEXAGON  
USING TRANSFORMTOOLPATH 
 
 In this task you will use Transform Toolpath to rotate the first contour toolpath to complete 

the machining of the remaining faces of the hexagon. 

 
 
1. In the Toolpaths manager select only the first contour operation, as indicated by the blue 

checkmarks shown below. 

 
 
2.  From the menu bar select Toolpaths>Transform… 
3. On the Types and Methods page set the following.  Ensure there is a check for the contour 

operation in the Source operations list.  Set options as shown below: 
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4. Now click on the Rotate tab and set the following: 

 

Start angle  

 
Sets the beginning 
angle for the rotate 
toolpath. 
 
Rotation angle 

 
Sets the angle of 
rotation for the 
transform toolpath. 

 

 
5. Next activate Rotation view and then click on the Select view icon. 

 

Rotation view 
Select this option to rotate the transformed 
toolpaths in a different plane than the original.  
If this option is inactive, the toolpath rotates in the 
original tool plane. 

 
6. You will be confronted with the View Selection dialog box, select RIGHT SIDE and de-

activate Set new origin as shown below: 
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7. Select the OK button  to exit the View Selection dialog box. 

8. Select the OK button  to exit the Transform Operations Parameters dialog box. 
9. Save your Mastercam file. 

10. Activate a shaded view by selecting the icon at the top of the screen. . 
11. Backplot all the toolpaths. 

12. To pick all the operations to Backplot pick the Select All icon  circled below: 
 
26. The next step is to select the Backplot selected operations icon shown below: 

 
 
27. Maximize the Backplot/Verify window if required.   
28. Select the Home Tab if required. 
29. Activate the options shown below in the Visibility section of the Home tab. 

 
 
30. Click on the Backplot tab at the top left of the screen. 

 
31. Activate the Both option in the Toolpath section of the Backplot tab. 

 
 
32. In the lower right corner of the screen now set the run Speed to slow by moving the slider 

bar pointer over to the left as shown below. 
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33. Now select the Play Simulation button to review the toolpaths. 

 
 

34. After reviewing the Backplot of the toolpath use the Close button  to exit Backplot. 
 
 Your part should look similar to the screen shot below.   
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TASK 7:   
MACHINE THE FIRST FACE OF THE SQUARE 
 In this task you will use a 0.75” diameter flat end mill to rough and finish the first face of the 

square.   
 For this example you will copy the first contour operation used to machine the first face of 

the hexagon and then modify the copied operation to machine the first face of the square. 

 

1. Activate a wireframe view by selecting the icon at the top of the screen. . 
2. In the Toolpaths manager select only the first contour operation, as indicated by the blue 

checkmarks shown below. The contour operation for the hexagon is the first operation.  

 
 
3. To copy this operation Hold down the Right mouse button over the folder for this 

operation.  Keep holding the right mouse button down and drag below the red arrow and 
release.  

4. Select Copy after from this menu. 
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5. Your screen will look similar to the screenshot below on the left. Move the Insert arrow   

to the bottom of the list of operations by clicking the  icon on the Toolpaths Manager 
toolbar: 

    
 
6. In the Toolpaths Manager click on the Geometry icon for the third operation as shown 

below: 

 
 
7. In the Chain Manager right mouse click on Chain 1 and select Rechain Single. 
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8. On the screen you will now see the Chaining dialog box.  Select Single chain. 

 
 
9. On the graphics screen is now a prompt to Add chain 1. Zoom in as required and select the 

single line shown below: 

 
 
10. After selecting the line your graphics screen should look like the screenshot above, with the 

green arrow pointing left.  If the arrow is not pointing to the left select the arrow  from 
the Chaining dialog box to reverse the direction. 

11. After the contour has been successfully chained select the OK button  at the bottom of 
the Chaining dialog box. 

12. Select the OK button  at the bottom of the Chain Manager box. 
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13. In the Toolpaths Manager click on the folder Parameters for the third operation as shown 
below: 

 
 
14. All the parameters and values you set in the first contour operation will still be set.   No 

changes required for: Tool, Cut Parameters, Lead/In/Out, Linking Parameters, Planes and 
Coolant. 

 
 
15. Select Multi Passes from the list on the left and ensure Multi Passes are activated by 

clicking on the small Multi Passes box.   Make changes to this page as shown below: 
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16. Select the OK button  to exit Contour parameters. 

17. Select the Regenerate all dirty operations button  to remove the red X from the 
contour operation you have just edited.   

18. Save your Mastercam file. 
19. Backplot this toolpath. 
 

TASK 8:   
MACHINE REMAINING FACES OF SQUARE  
USING TRANSFORMTOOLPATH 

 
 In this task you will use Toolpath>Transform to machine the remaining faces of the square. 
 
1. In the Toolpaths manager select only the third contour operation, as indicated by the blue 

checkmarks shown below. 

 
 
2.  From the menu bar select Toolpaths>Transform… 
3. On the Types and Methods page set the following.  Ensure there is a check for the contour 

operation in the Source operations list.  Set options as shown below: 
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4. Now click on the Rotate tab and set the following.  If required click on the Select view icon 
and select RIGHT SIDE.  

 

Start angle  

 
Sets the beginning 
angle for the rotate 
toolpath. 
 
Rotation angle 

 
Sets the angle of 
rotation for the 
transform toolpath. 

 

 
 

5. Select the OK button  to exit the Transform Operations Parameters dialog box. 
6. Save your Mastercam file. 

7. Activate a shaded view by selecting the icon at the top of the screen. . 

8. Backplot all the toolpaths. To pick all the operations to Backplot pick the Select All icon . 
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TASK 9: 
MACHINE POCKET ON BACK FACE 
 In this task you will use a 0.25” diameter flat end mill to rough and finish the pocket on the 

BACK face using Toolpath>Pocket. 
 In this task you will not use the standard BACK Tplane, but will create a new Tplane using 

Rotate planes from the Planes menu on the Status bar. 

 
1. Select Alt-T on your keyboard to turn off the display of toolpaths. 

2. Set the graphics view to Isometric View.  

3. Select the Screen Fit icon found at the top of the screen to fit the part to the screen .   
4. Activate a shaded view by selecting the icon at the top of the screen. 

  
 
5. Select Planes from the Status bar. 

 
 
6. Select Rotate planes. 

 
 
7. Set the About X value to -90. 

 
 

8. Click on the OK button when done . 
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9. In the New View dialog box change the name to NEW VIEW BACK.  Make changes as 
shown below: 

 
 

10. Click on the OK button when done . 
11. At the bottom of the graphics screen you will now see T/Cplane: NEW VIEW BACK 

 
 
12. Dynamically rotate the display similar to the display shown below. The text BACK is facing 

up. 

 

Note  
At the bottom of the graphics 
screen the status of the Tool and 
Construction plane is set to NEW 
VIEW BACK.  
 
 

13. Activate a wireframe view by selecting the icon at the top of the screen. . 
14. From the menu bar select Toolpaths>Pocket… 
15. On the screen you will now see the Chaining dialog box. Activate C-Plane and ensure 

Chain is selected. 
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16. On the graphics screen is now a prompt to Select pocket chain 1 Zoom in as required and 
select the line at the top of the BACK pocket as shown below: 

 
 
17. After selecting the line your graphics screen should look like the screenshot below, with the 

green arrow pointing left in a clockwise direction. If the arrow is not pointing to the left 

select the arrow  from the Chaining dialog box to reverse the direction. 

  
   

18. After the chain has been successfully chained select the OK button  at the bottom of 
the Chaining dialog box. 

19. Ensure the Toolpath Type is set to Pocket. 
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20. On the left of the dialog box select Tool.  Click on the Select library tool button and choose 
a 1/4” Flat End Mill.  .  Make changes to this page as shown below: 

 
 
21. Select Cut Parameters from the list on the left and make changes to this page. 
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22. Select Roughing from the list on the left and make changes to this page. 

 
 
23. Select the plus sign to the left of Roughing to expand the list (if required) and click on Entry 

Motion and make changes to this page. 
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24. Select Finishing from the list on the left and make changes to this page: 

 
 
25. Select the plus sign to the left of Finishing expanding the list and click on Lead In/Out. 
26. Ensure the Lead In/Out is activated by clicking on the small Lead In/Out box and make 

certain the green check mark is showing. Make the following changes as shown below: 
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27.  Select Depth Cuts from the list on the left and make changes to this page: 

 
 
28. Select Break Through from the list on the left and make changes to this page: 
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29. Select Linking Parameters from the list on the left and make changes to this page as 
shown below. 

 
 
30. Scroll down the list on the left and select Planes(WCS).  Set the Work offset to Zero.   

 

Work Offset # 
Assigns a work 
offset code to the 
view. When you 
use the view for a 
Tplane and create 
a toolpath (or 
wirepath),  
 
Mastercam will 
automatically 
output the work 
offset when you 
post the operation. 
Number the offsets 
sequentially from 
zero, or enter –1 to 
not assign any 
offset to the view.  
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31. When confronted with the Update View dialog box activate Update just this operation 
without changing the view. 

 
 

32. Click on the OK button when done . 
33. Select Coolant from the list on the left. Open up the drop down menu for Flood and set it to 

On. 

34. Select the OK button  to exit Pocket operation. 
35. Save your Mastercam file. 
36. Backplot this toolpath only. 
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TASK 10:  
MACHINE OPEN POCKET ON BOTTOM FACE 
 In this task you will use the 0.25” diameter flat end mill to rough and finish the open pocket 

on the bottom face using Toolpath> Pocket. 
 
1. If required select Alt-T on your keyboard to turn off the display of toolpaths.   
2. Activate a shaded view by selecting the icon at the top of the screen. 

  
 
3. Open the Plane drop down menu on the Top toolbar and select Named Views... 

 
 
4. You will be confronted with the View Selection dialog box, select BOTTOM and de-activate 

Set new origin as shown below: 

 
 

5. Select the OK button  to exit the View Selection dialog box. 
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6. Dynamically rotate the display similar to the display shown below. The text BOTTOM is 
facing up. 

 

Note  
At the bottom of the graphics 
screen the status of the Tool and 
Construction plane is set to 
BOTTOM.  
 
 

7. Activate a wireframe view by selecting the icon at the top of the screen. . 
8. From the menu bar select Toolpaths>Pocket… 
9. On the screen you will now see the Chaining dialog box. Activate C-Plane and select 

Partial chain. 
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10. On the graphics screen is now a prompt to Select the first entity. Zoom in as required and 
select the line at the bottom of the pocket as shown below: 

 
 
11. After selecting the line your graphics screen should look like the screenshot below, with the 

green arrow pointing right in a clockwise direction. If the arrow is not pointing to the right 

select the arrow  from the Chaining dialog box to reverse the direction. 
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12. After selecting the first line in the Partial chain you are then prompted to Select the last 
entity.  Select the line at the bottom of the slot as shown below: 

 
 

13. After the contour has been successfully chained select the OK button  at the bottom of 
the Chaining dialog box. 

14. Ensure the Toolpath Type is set to Pocket. 
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15. On the left of the dialog box select Tool.  Select the 1/4” Flat End Mill.  Make changes to 
this page as shown below: 

 
 
16. Select Cut Parameters from the list on the left and make changes to this page. The Pocket 

type should be set to Open.  Activate Use open pocket cutting method. 
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17. Select Roughing from the list on the left and make changes to this page. 

 
 
18. Select the plus sign to the left of Roughing to expand the list (if required) and click on Entry 

Motion. 

 
 
19. Select OFF in the Entry Motion page. 
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20. Select Finishing from the list on the left and make changes to this page: 

 
 
21. Select the plus sign to the left of Finishing expanding the list and click on Lead In/Out. 
22. Ensure the Lead In/Out is activated by clicking on the small Lead In/Out box and make 

certain the green check mark is showing. Make the following changes as shown below: 
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23. Depth Cuts and Break Through should not be activated.  

 
 
24. Select Linking Parameters from the list on the left and make changes to this page as 

shown below. 
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25. Scroll down the list on the left and select Planes(WCS).  Set the Work offset to Zero.   

 

Work Offset # 
Assigns a work 
offset code to the 
view. When you 
use the view for a 
Tplane and create 
a toolpath (or 
wirepath),  
 
Mastercam will 
automatically 
output the work 
offset when you 
post the operation. 
Number the offsets 
sequentially from 
zero, or enter –1 to 
not assign any 
offset to the view.  

 
26. Select Coolant from the list on the left. Open up the drop down menu for Flood and ensure 

it is set to On. 

27. Select the OK button  to exit Pocket operation. 
28. Save your Mastercam file. 
29. Backplot this toolpath 
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TASK 11:   
MACHINE POCKET ON TOP FACE 
 In this task you will use a 0.25” diameter flat end mill to rough and finish the pocket on the 

TOP face 
 For this example you will copy the fifth operation used to machine the pocket on the BACK 

face and then modify this copied operation to machine the pocket on the TOP face. 

 

1. Set the graphics view to Isometric View.  

2. Activate a shaded view by selecting the icon at the top of the screen. . 
3. Now dynamically rotate the display similar to the display shown below. The text TOP is 

facing up. 

 

Note  
At the bottom of the graphics 
screen the status of the Tool and 
Construction plane is set to TOP. 
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4. Before moving on, let’s organize the operations in the Toolpaths Manager.  Click on the 
minus sign for each operation to collapse the tree structure of these operations. 

 
 
5. In the Toolpaths manager select only the fifth Pocket operation, as indicated by the blue 

checkmarks shown below. This fifth operation is used to machine the pocket on the BACK 
face.  

 
 
6. To copy this operation Hold down the Right mouse button over fifth.  Keep holding the 

right mouse button down and drag below the red arrow and release.  
7. Select Copy after from this menu. 

 

8. Your screen will look similar to the screenshot below on the left. Move the Insert arrow   

to the bottom of the list of operations by clicking the  icon on the Toolpaths Manager 
toolbar: 
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9. In the Toolpaths Manager click the plus sign to the left of operation 7 Pocket to expand 
the list.  Now click on the folder Parameters for the seventh operation as shown below: 

 
 
10. All the parameters and values you set earlier in this copied pocket operation will still be set.   

The Only changes required are for Linking Parameters and Planes (WCS).  Select 
Linking Parameters and make changes to this page as shown below.  The Depth is set in 
Incremental at a depth of -0.25. 

 
 
11. Scroll down the list on the left and select Planes(WCS).  The Tool plane and Construction 

plane is set to NEW VIEW BACK at present.  You need to change the Tool plane to TOP. 
Click on the Select tool plane view icon. 
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12. In the View Selection dialog box select TOP and un-check Set new origin. 

 
 
13. Click on the OK button when done. 
14. When returned to the Planes page note now that the Tool plane is set to TOP, but the 

Comp / construction plane is set to NEW VIEW BACK.  Click on the right Copy button to 
transfer the Tool plane settings over to the Comp / construction plane settings. 
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15. Now set the Work offset to Zero.   

 
 
16. When confronted with the Update View dialog box activate Update just this operation 

without changing the view. 

17. Click on the OK button in the Update View dialog box when done . 

18. Select the OK button  to exit Pocket parameters. 
19. Now click on the Geometry icon for the seventh operation as shown below: 

 
 
20. In the Chain Manager right mouse click on Chain 1 and select Rechain all. 
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21. On the screen you will now see the Chaining dialog box. Activate C-Plane and ensure 
Chain is selected. 

 

Cplane 
Chains only entities that are parallel to the current 
construction plane and at the same Z depth as the first 
entity you chain. In Window, Area, or Polygon chaining, 
chains only entities that are on the current construction 
plane and at the current Z depth. 
 

 
22. On the graphics screen is now a prompt to Add chain 1. Zoom in as required and select the 

line in this pocket as shown below: 

 

Note  
At the bottom of the graphics 
screen the status of the Tool and 
Construction plane is now set to 
TOP.   
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23. After selecting the line your graphics screen should look like the screenshot below, with the 

green arrow pointing left.  If the arrow is not pointing to the left select the arrow  from 
the Chaining dialog box to reverse the direction. 

 

24. After the contour has been successfully chained select the OK button  at the bottom of 
the Chaining dialog box. 

25. Select the OK button  at the bottom of the Chain Manager box. 

26. Select the Regenerate all dirty operations button  to remove the red X from the 
contour operation you have just edited.   

27. Click on the minus sign to the left of this last operation to collapse it. 
28. Save your Mastercam file. 
29. Backplot this toolpath. Sam
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TASK 12:   
DRILL HOLES ON FRONT FACE 
 In this task you will drill the two holes on the front face with a 0.25” centre cutting Flat 

End Mill. 

 
 
1. Activate a shaded view by selecting the icon at the top of the screen. 

  
 
2. Dynamically rotate the display similar to the display shown below. The text TOP is facing up. 

 

Note  
At the bottom of the graphics 
screen the status of the Tool and 
Construction plane is set to TOP.  

 
3. Open the Plane drop down menu on the top toolbar and select FRONT (WCS). 

 
 
4. At the bottom of the graphics screen you will now see T/Cplane: FRONT 
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5. From the menu bar select Toolpaths>Drill… 
6. Now you are prompted to Select points and the Drill Point Selection dialog box appears.  All 

you need to do now is snap to the centre of the two circles.  Move the mouse and position 
the cursor over the center of the left circle shown below, you will notice a circle appears 
as you move closer to the center of the circle, this is the visual cue for Arc center. Ensure 
the visual cue for Arc center point appears before you select the point.  Use the left 
button of your mouse to pick this center point.  Now select the centre of the second hole 
using the same method. 

 
 

7. Select the OK button   in the Drill Point Selection dialog window to complete the 
selection of points. 

8. Ensure the Toolpath Type is set to Drill. 

 
 

9. Select the 1/4” flat end mill  Change the page parameters as shown below: 
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10. Select the Linking Parameters page and make the changes as shown below.  

 
 
11. Tip Comp should not be activated. 
12. From the list on the left select Planes(WCS).  Ensure the values are as below. Work offset 

to Zero.   

 
 
13. Select the Coolant page, and set Flood to On: 

14. Select the OK button  to complete this drilling function. 
15. Click on the minus sign to the left of this last operation to collapse it. 
16. Save your Mastercam file. 
17. Backplot this toolpath. 
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TASK 13:   
DRILL HOLE ON HEXAGON AT FRONT 
 
 In this task you will drill the hole on the hexagon at the front with a 0.25” centre cutting Flat 

End Mill. 

 

1. Select an Isometric view  and then Screen Fit . 
2. Dynamically rotate the display similar to the display shown below. The text TOP is facing up. 

 

Note  
At the bottom of the graphics 
screen the status of the Tool and 
Construction plane is set to TOP.  

 
3. Select WCS>View Manager from the Status bar. 

 
 
4. From the View Manager Dialog box select the Geometry button as shown below. 

 

Geometry 
Click the Geometry button to create a new view based on 
geometry in your part.  
 
Mastercam will prompt you for the necessary geometry and 
other information needed to create the view. 
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5. At the graphics screen you will be prompted to: Set construction plane by geometry 
Cplane by geometry. Select the arc of the hole shown below.  Make sure the XYZ tripod 
is the same as the example below right with the Z axis arrow pointing up from the hole, X 
axis pointing to the right as shown below right. Use the arrow buttons in the Select view 
screen to cycle through to the correct coordinate system. 

            
        
6. Select the green check mark for OK. 
7. In the New View dialog box enter NEW VIEW HEX HOLE in the name section. Un-check 

Set new origin. 

 
 

8. Click on the OK icon  to complete this feature.  
9. Now you are back in the View Manager dialog box pick in the C (Cplane) column and T 

(Tplane) column of the NEW VIEW HEX HOLE row as shown below. 
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10. In the lower right of the view manager dialog window change the origin coordinates to X0 Y0 
Z0. 

 
 
11. Your View Manager dialog box should look like the image below: 

 
 

12. Click on the OK icon  to complete this feature.  
13. At the bottom of the graphics screen you will now see T/Cplane: NEW VIEW HEX  HOLE 

(Not Saved) 
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14. From the menu bar select Toolpaths>Drill… 
15. Now you are prompted to Select points and the Drill Point Selection dialog box appears.  All 

you need to do now is snap to the centre of the circle.  Move the mouse and position the 
cursor over the center of the circle shown below, you will notice a circle appears as you 
move closer to the center of the circle, this is the visual cue for Arc center. Ensure the 
visual cue for Arc center point appears before you select the point.  Use the left button of 
your mouse to pick this center point.  

 
 

16. Select the OK button   in the Drill Point Selection dialog window to complete the 
selection of points. 

17. Ensure the Toolpath Type is set to Drill. 
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18. Select the Tool page select the 1/4” flat end mill  Ensure the page parameters are as 
shown below: 

 
 
19. Select the Linking Parameters page and make the changes as shown below.  

 
  
20. Tip Comp should not be activated. 
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21. From the list on the left select Planes(WCS).  Ensure the values are as below. Work offset 

to Zero.  Click on the View Selection button to select a new view  . 
 

 
 
22. When confronted with the Update View dialog box activate Update just this operation 

without changing the view. 

 
 

23. Click on the OK button when done . 
24. Select the Coolant page, and set Flood to On: 

25. Select the OK button  to complete this drilling function. 
26. Click on the minus sign to the left of this last operation to collapse it. 
27. Save your Mastercam file. 
28. Backplot this toolpath. 
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TASK 14:   
DRILL HOLE ON HEXAGON AT BACK  
USING TRANSFORM TOOLPATH 
 In this task you will a drill hole on the hexagon with a 0.25” centre cutting Flat End Mill. 
 You will use Toolpath>Transform to drill the hole on the back face of the hexagon. 

 
 
1. In the Toolpaths manager select only the ninth operation, as indicated by the blue 

checkmarks shown below. 

 
 
2.  From the menu bar select Toolpaths>Transform… 
3. On the Types and Methods page set the following.  Ensure there is only a check mark for 

the ninth drill operation in the Source operations list.  Set options as shown below: 
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4. Now click on the Rotate tab and set the following.  If required click on the Select view icon 
and select RIGHT SIDE.  

 

Start angle  

 
Sets the beginning 
angle for the rotate 
toolpath. 
 
Rotation angle 

 
Sets the angle of 
rotation for the 
transform toolpath. 

 

 
 

5. Select the OK button  to exit the Transform Operations Parameters dialog box. 
6. Click on the minus sign to the left of this last operation to collapse it. 
7. Save your Mastercam file. 
8. Backplot this toolpath. 
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TASK 15:  
VERIFY THE TOOLPATHS USING A SUPPLIED STL FILE 
 Mastercam's Verify utility allows you to use solid models to simulate the machining of a part.  
 If you are using a Training Guide to go through this Lesson the required STL file is on the 

multimedia DVD that came with this text in a folder called Mastercam Files. If you are using 
the Online Course content this file is available in Step 2 of this Lesson on the online content 
screen. 

 
1. Locate the supplied STL file FOUR-AXIS-LESSON-3.STL and copy the file to the same 

folder that your Mastercam files resides in. 
2. For a better view of the part use the toolbar at the top of the screen to change the graphics 

view to Isometric.  

 

3. Select the Screen Fit icon found at the top of the screen to fit the part to the screen . 
4. Now dynamically rotate the display similar to the display shown below. The text TOP is 

facing up. 

 

5. In the Toolpaths Manager pick all the operations to verify by picking the Select All icon  
6. In the Toolpaths Manager pick the Backplot/Verify Options icon. 
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7. In the Backplot/Verify Options window activate the radio button for File and then select the 
Browse icon. 

 
 
8. Select the FOUR-AXIS-LESSON-3.STL file and then click on Open. Please Note: The STL 

file is supplied on the multimedia DVD that came with this text in a folder called Mastercam 
Files. 

9. Select the OK button  to exit Backplot/Verify Options. 
10. Select the Verify selected operations button shown below: 

 
 
11. Maximize the Backplot/Verify window if required. 
 
12. Activate the options shown below in the Visibility section of the Home tab. Initial Stock and 

Toolpath not activated. 
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13. The stock appears as below: 

 
 
14. Activate the Color Loop to change the color of the tools for the verified part. 
15. In the lower right corner of the screen now set the run Speed to slow by moving the slider 

bar pointer over to the left as shown below. 

 
 
16. Now select the Play Simulation button to review the toolpaths. 

 
 

 
 

17. Select the Close button    in the top right hand corner to exit Verify. 
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TASK 16:  
POST AND CREATE THE CNC CODE FILE 

1. Ensure all the operations are selected by picking the Select All icon  from the 
Toolpaths Manager. 

2. Select the Post selected operations button from the Toolpaths Manager. 

 
 
3. In the Post processing window, make the necessary changes as shown below: 

 
 

4. Select the OK button  to continue. 
5. Click on OK in the Work offset dialog box. 

 
 
6. Enter the same name as your Mastercam part file name in the NC File name field FOUR-

AXIS-LESSON-3. 
7. Select the Save button. 
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8. Scroll down and review the NC file.  Note the various A-Axis moves to machine the pockets 
and holes. 

 
 

9. Select the  in the top right corner to exit the CNC editor. 
10. This completes Four-Axis-Lesson-3. 
 

FOUR-AXIS-LESSON-3 EXERCISES 
 

 If you are using a Training Guide the required exercise files are on the multimedia DVD that 
came with this text in a folder called Mastercam Files. If you are using the Online Course 
content the exercise files are available in this Lesson on the online content screen. 

 

FOUR-AXIS-LESSON-3 EXERCISE #1 

 
 
FOUR-AXIS-LESSON-3 EXERCISE #2 
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FOUR-AXIS-LESSON-3 EXERCISE #1 
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FOUR-AXIS-LESSON-3 EXERCISE #2 
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