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Objectives 
 
You will import a Mastercam Art Library file and use it to create a surface. You will generate a 
toolpath to machine the part on a CNC router or mill. This lesson covers the following topics: 
 
 Import a Mastercam Library File: 
Setting the size and depth attributes 
Creating an Organic Surface 
Creating a Texture 
Modifying Surfaces 
Defining the top of the workpiece 
 
 Creating the Toolpath: 
Selecting the proper cutting tool 
Setting feeds and speeds 
Selecting the proper toolpath 
Posting the G-code 
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TOOL LIST 
 One cutter will be used to create this part. 
 The .125” diameter ball endmill will be used to machine the picture. 
  

Item Description 
Saved Mastercam File Lesson-6-yourname.mcx 
Cutter(s) type 0.125 Ball Endmill 1/8” Ball Endmill 
Material size 6” x 3” x 0.5” 
Material Type Wood or Plastic 
Feed rate 14 inches per minute 
Spindle speed 5000 RPM 
Stepover 10% 
Saved NC File Lesson-6-yourname.nc 

 

LESSON-6 THE PROCESS 
 

Geometry Creation (CAD) 
TASK 1:  Set the environment 
TASK 2:  Create a 3” x 3” rectangle 
TASK 3:  Create a circle inside the rectangle 
TASK 4:  Import the File into Mastercam Art 
TASK 5:  Create the canvas 
TASK 6:  Introduce the Art Manager 
TASK 7:  Create an organic surface 
TASK 8:  Add texture 
TASK 9:  Add an organic surface 
TASK 10:  Make the top of the image Z- zero 
 

Toolpath Creation (CAM) 
TASK 11:  Define the rough stock using stock setup 
TASK 12:  Machine the part 
TASK 13:  Backplot the toolpath 
TASK 14:  Verify the toolpath 
TASK 15:  Save updated MCX file 
TASK 16:   Post and create the CNC code file 
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Geometry Creation (CAD) 
TASK 1: 
SET THE ENVIRONMENT 
 
Before starting the geometry creation and generating the toolpaths you should: 
 
 Set up the grid. 
 Customize the toolbars to machine a 2D part. 
 Set the machine type. 
 
TASK 1A: 
SET THE DISPLAY OF THE GRID 
1. Launch Mastercam. 
2. Select from the pull down menu Settings>Configuration… 

 
 

3. From the Topics pane on the left side of this dialog box expand the Screen topic by 
selecting the + sign as shown below. 

4. Click on Grid Settings as shown below. 
5. Enable the Visible Grid and change the Size to 1.0 as shown below. 

 
 
6. Select the OK  button to complete this function. 
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TASK 1B: 
SET THE TOOLBARS REQUIRED TO CREATE THE GEOMETRY AND 
MACHINE A 2D AND/OR A 3D PART 
 
1. Select from the pull down menu Settings>Toolbar States… 
2. Select 2D-Toolpaths. 

3. Then select the Load button . 

 
 
4. Select the OK button  to accept the settings. 
 
 To Show or Hide the Operations Manager pane on the left of the screen press Alt + O. 

Pressing Alt + O acts like a toggle switch between Show and Hide. For more information on 
the Operations Manager, see the Tips and Techniques section on the multimedia CD 
supplied with this course. 

5. The Mastercam interface will be displayed as shown below when the Operations Manager is 
hidden. 
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TASK 1C: 
SELECT THE TYPE OF MACHINE 
 You may have to check with your Instructor to determine the CNC Machine you will use to 

machine the part in this lesson.  
 If you do not have the appropriate post processor for the CNC Machine in your class use the 

Default Machine to complete this lesson. 
 To set the machine type do the following: 
 
1. If you are using a CNC Mill continue to step 2. If you are using a CNC Router continue to 

step 5. 
2. Select from the pull down menu Machine Type>Mill. 
3. Click on (your cnc machine).mmd machine type. In the example below a techno.mmd is 

selected, which is the Machine Definition for a Techno CNC Mill. For the purpose of this 
lesson we will use the Default Machine or (Mill Default.mmd). 

 
 
4. Continue to step 7. 
5. If you are using a CNC Router: select from the pull down menu Machine Type>Router. 
6. Click on (your cnc machine).rmd machine type. In the example below a techno.rmd is 

selected, which is the Machine Definition for a Techno CNC Router. For the purpose of 
this lesson we will use the Default Machine or (Router Default.rmd). 

 
 
7. To display the Toolpath Manager press Alt + O. 
8. The Toolpath Manager should look as shown below. 

 
 
9. You are now ready to proceed with your lesson. 
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CREATE A RECTANGLE 3” X 3” 
 This task explains how to create the 3” x 3” rectangle. These four lines could be created in 

many different ways, this is just one option. 
 
1. Select from the pull down menu Create>Rectangle… 

 
 
2. The Create Rectangle ribbon bar appears and you are prompted to Select position of first 

corner. 

 
 

3. On the ribbon bar click in the Width field  and enter a value of 3.0. Press the Tab key 
and you will be moved over to the Height field. 

 

 
 

4. In the Height  field enter a value of 3.0 and then press Enter. 
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5. Move the cursor to the center of the Grid and click the mouse button (snap) on the Origin 
for the base point as shown below.  

 
 
6. Click on the OK icon  to complete this feature.  

7. Select the Fit to screen icon found at the top of the screen to fit the part to the screen . 

 
 
8. Your graphics window should look like the screenshot below. 
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TASK 3: 
CREATE A CIRCLE INSIDE THE RECTANGLE 
 
 We will add a circle to provide more features to our project. 
 
1. From the pull down menu bar click on Create>Arc>Circle Center Point… 

 
 
2. The Create Arc ribbon bar appears and you are prompted to Enter the center point. On 

the ribbon bar enter 1.5 in the X field (1) and press the Tab key. Enter 1.5 in the Y field (2) 
and press the Tab key. Press Enter and then enter 2.75 in the Diameter field (3). Then 
click on the OK button (4). 

  
 
3. Your screen should look like the screenshot below. 
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TASK 4: 
IMPORT THE FILE INTO MASTERCAM ART 
 
 In this lesson we will use a file that comes with Mastercam. This file is located on the CD 

that accompanies this course, or it may be in a folder on the computer or on the computer 
network.  

Mastercam Art allows you to import all types of raster graphics (BMP, GIF, JPG or JPEG, PCD, 
PCX, TIF or TIFF), including images that have been digitized with a scanner or digital camera. 
Raster graphics, also referred to as bitmap images, are drawn as an array of squares (pixels). 
Vector graphics are drawn as lines, polygons and text, 
 
1. To locate the file on the system, select Art>Browse Classic Design Library…  

 
 
2. Double click on the insects Folder as shown below. Note: If the file is not located on the 

computer or computer network, then locate the CD that accompanies this book and use the 
same instructions in Steps 2 through 4 except look on the CD for the file n01e16.mcx in the 
Mastercam Files folder on the CD. If you are opening the file from the CD then change the 
Files of type in the Open screen to .mcx. 
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3. Click on n01e16.mzx (1) and make sure that the image (2) displayed in the preview screen 
looks the same as shown below. Click on the Open button. 

 
 
4. The Redefine Keys dialog box displays next, as shown below. Take note of the various 

commands that are available for when the image is brought into the Mastercam graphics 
window. 

 
 
5. Click on the OK  button. 
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6. The image of the butterfly is now visible and attached to your cursor (1). As you move the 
cursor, the image of the Butterfly will move as if it is attached to it. Note that the prompt 
states: Please press H for help (2).  

 
 
7. Move the mouse so the butterfly is in the middle of the rectangle as shown below. 

IMPORTANT: Do not click the mouse button yet. 

- 
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8. Press the H key on your keyboard. The Redefine 
Keys dialog box appears again, as shown on the 
right. This dialog box displays any time you press the 
H key and shows the keys needed to manipulate the 
butterfly Image. 

9. Make sure the Scale Factor is set to 2.000 as 
shown to the right. 

10. Click on the OK button . 
  
 

 
11. Press the + (plus) key on your keyboard once. The image should increase in size. 
12. Make sure the butterfly is in the center of the Rectangle and Click the Left Mouse Button 

to position the butterfly. 
13. Press the Esc key on your keyboard. 
14. Your screen should look like the screenshot below. 
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TASK 5: 
CREATE THE CANVAS 
 
 In this task we will create a 3” x 3” Art Base Surface on the existing rectangle. 
 
1. From the pull down menu click on Art>New Art Base Surface>Rectangular… 

 
 
2. The Rectangular dialog box appears. Make sure that 

the Surface Extents (1) is set to Create Art Base 
Surface by specifying 2 points as shown to the right. 

3. Click on the Lower Left Point selector button (2) as 
shown to the right. 

4. You are prompted to Please select lower left corner 
for the new Art Base Surface. Click on the Lower 
Left corner of the rectangle on your screen as shown 
below. 
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5. The Rectangular dialog box appears again. Click on 

the Upper Right Point selector button (3) as shown to 
the right. 

6. You are prompted to Please select upper right 
corner for the new Art Base Surface. Click on the 
Upper Right corner of the rectangle on your screen as 
shown below. 
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7. The Rectangular dialog box appears again.  
8. Click on Z-Limit to turn it on (4) the change the Z-Limit 

dimension to 0.2500 (5) as shown in the image on the 
right. 

9. Click on OK .  
10. Your screen should look like the screenshot below. 

 
11. Select the Alt key and hold it down while selecting the 

S key on your keyboard (Alt + S). The image will turn 
to a solid color. 

12. Select Alt + S again to toggle the image back. You will 
use this key sequence later in the lesson to view the 
newly created features in the image. 

 
13. Save your work by clicking on the pull down menu File>Save As… 
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14. Type in LESSON-6-ART-(your)NAME.MCX as shown below. 

 
 
TASK 6: 
INTRODUCE THE ART MANAGER 
 
 The Art Manager is used to make changes to the Art features in your part and provides 

various ways to view your part. 
 
1. Click on the Art Tab in the Operations Manager as shown below. Note: If the Operations 

Manager is not visible, press Alt + O to make it visible. 

 
 
2. The Operations Manager should now look like the screenshot below. Art Base Surface 

#1 is the default name of the new Art Base Surface you created in Task 5. 
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TASK 7: 
CREATE AN ORGANIC SURFACE 
 
 We will use the Organic Surface feature in Art to add 3-dimensional features to the 

butterfly. 
 
1. From the pull down menu click on Art>Create Art Surface Operation>Organic… 

 
 
2. You will be prompted to Select one or more chains for Contour 1 and the Chaining 

dialog box appears. Make sure the Chain button is selected as shown below. 
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3. Click on the outline of the butterfly as shown below. 

 
 
4. Click on the OK  button in the Chaining dialog box. 
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5. The Organic dialog box appears next as shown to the 
right. 

6. Change the Radius (1) to 0.250. 
7. Make sure the Application Style (2) is set to Add.  
8. Change the Adjust Ridge (3) to Parabola Low by clicking 

in the Adjust Ridge field. 
9. Click on the OK button . 

 
 
10. When the Name the Operation dialog box appears, click on the OK button  to 

accept the default name. To dismiss the naming dialog box, put a check mark in front of 
Don’t show this message again in this session. 
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11. Your screen should look like the screenshot below. Note that the butterfly (1) has a 
3-dimensional shape, and the addition of the Organic – Add Operation (2) in the Art 
Manager. 

 
 
12. Click on the Hide Art Model button as shown below. Notice the surface model is no longer 

visible and only the lines and arcs are visible. 

 
 
13. From the pull down menu, click on Art>Create Art Surface Operation>Organic… 
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14. You are prompted to Select one or more chains for Contour 1 and the Chaining dialog 
box appears. Make sure the Chain Button is selected and click on the four inside 
contours as shown below. 

 
 
15. Click on the OK button  in the Chaining dialog box. 
 
16. The Organic dialog box appears next as shown to the 

right. 
17. Change the Radius (1) to 0.1250. 
18. Make sure the Application Style (2) is set to Sub.  
19. Click on OK . 
20. Click on the Hide Art Model button to unhide the art 

model. 
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21. Your image should look like the screenshot below. 

 
 

22. Click on  Isometric Gview . Notice the butterfly is no 3 Dimensional (3D). 
23. Your screen should look similar to the image below. 

 
 

24. Click on Top Gview . 
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TASK 8: 
ADD TEXTURE 
 
1. Unshade the image by pressing the Alt + S keys on your keyboard, or by clicking on the 

wireframe icon . 
2. Hide the Art Model by clicking on the Hide Art Model icon as shown below. 

 
 
3. From the pull down menu, click on Art>Create Textures>Handcrafted Textures… 

 
 
4. The Chaining dialog box appears and you are prompted to Select one or more chains 

for Contour 1. Click on the circle first then on the butterfly outline second, as shown 
below. 
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5. Select OK  in the Chaining dialog box. 
6. The Handcrafted dialog box appears next. Keep the default 

settings as shown to the right. 
7. Click OK . 

8. Click on the Hide Art Model Icon  to unhide the Art Model. 
9. Your screen should look like the screenshot below. 

 
 
 
10. Turn on the shading by selecting the Alt + S keys on your keyboard or by selecting the 

Shade Icon . 

11. Change the graphics view of the image by clicking on the Isometric icon . 

12. Click on the Fit to screen icon . 
13. Your screen should look like the screenshot below. 
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TASK 9: 
ADD AN ORGANIC SURFACE 
 
1. Unshade the image by selecting the Alt and S key on your keyboard or by clicking on the 

wireframe icon . 
2. Hide the Art Model by clicking on the Hide Art Model icon as shown below. 

 

3. Change the graphics view to Top by clicking on the Top Icon . 
4. From the pull down menu, click on Art>Create Art Surface Operation>Organic… 

 
 
5. The Chaining dialog box appears and you are prompted to Select one or more chains 

for Contour 1. Click on the circle as shown below. 
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6. Select OK  in the Chaining dialog box. 
7. The Organic parameter screen appears. Make sure the 

Radius is 0.125 as shown to the right (1). 
8. The Application Style should be set to Add (2). 
9. The Adjust Ridge setting should be Arc Low (3). 
10. Click OK . 
11. The following window may appear. It is telling you that the 

height of the image will be created at 0.250” instead of 0.375” 
because we set the Height Limit to 0.250”. Click on OK. 

 

12. Click on the Hide Art Model Icon  to unhide the Art 
Model. 

13. Your screen should look like the screenshot below. 

 
 
 
14. Turn on the shading by selecting the Alt + S keys on your keyboard or by selecting the 

Shade Icon . 

15. Change the graphics view of the image by clicking on the Isometric icon . 
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16. Click on the Fit to screen icon . Your screen should look like the screenshot below. 
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TASK 10: 
MAKE THE TOP OF THE IMAGE Z ZERO 
 
 In this task we will move the image so the top is at Z Zero. 
 

1. Change the graphics view to Front . 

2. Select the Fit to screen button  to fit the geometry to the screen.  
3. The image should look like the example below. Notice that the bottom of the part is at the 

center of the Grid which is Z zero. 

 
 
4. From the pull down menu click on Art>Xform Art Base Surface> Shift Art Model below Z 

Zero… 
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5. Select the option Surface Top to. This will move the top of the Art base surface to the Z 
zero plane automatically. 

 
 

6. Select the OK button  to accept.  
7. The same warning window appears as in the previous task. Click OK to accept. 

 

8. Select the Fit to screen button  to fit the geometry to the screen.  
9. The image should look like the example below. Note that the Top of the part is now at Z - 

zero. 

 

10. Change the graphics view of the image by clicking on the Isometric icon . 

11. Click on the Fit to screen icon . 
12. Save the geometry by clicking on File>Save… or by clicking on the Save icon 

. 
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Toolpath Creation (CAM) 
TASK 11: 
DEFINE THE ROUGH STOCK USING STOCK SETUP 
1. For a better view of the part use the toolbar at the top of the screen to change the graphics 

view to Isometric. 

 

2. Select the Fit to screen icon . 
3. Move over to the Toolpath Manager by clicking on the Toolpaths tab as shown below. 

 
 
4. Select the plus (+) in front of Properties to expand the Toolpaths Group Properties. 

Pressing Alt + O will Show/hide Operations Manager pane. 
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5. Select Stock setup in the Toolpath Manager. 

 
 
6. Change the 5 settings to match the Stock Setup screenshot below. 
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7. Select the Tool Settings tab and change the parameters to match the Tool Settings 
screenshot below. To change the Material type, follow the next set of instructions. 

 
 
8. To change the Material type to Wood click the Select button at the bottom of the Tool 

Settings tab. 
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9. In the Material List dialog box open the Source drop down list and select Mill - library. If 
you are using a CNC Router, select Router - library. 

  
 
10. From the Default Materials list select WOOD inch and then select the OK button . 

You may have to check with your Instructor to determine the material to use. 

 
 
11. Select the OK button  again to complete this Stock Setup. 
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TASK 12: 
MACHINE THE PART 
1. From the pull down menu click on Art>Toolpath Art Base Surface… 

 
 
2. If you are prompted to Enter new NC name ensure that Lesson-6-Art-Organic-Name is 

displayed, and then select the OK button . If this dialog box does not appear proceed 
to the next step.  

 
 Note that it will take couple of minutes to open the Machine Art Base Surface. 
3. In the Machine Art Base Surface dialog box, click on the Select library tool… button as 

shown below. 
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4. Select the 1/8 Ball Cutter. 
 
 If the 1/8 Ball Cutterl is not in the Tool Selection list, follow the next steps. Otherwise 

proceed to Step 12. 
5. Select Filter button in the Tool Selection dialog box. 

 
 
6. In the Tool List Filter dialog box, select the None button in the Tool Types. 

 
 
7. Select the Endmill Sphere as the Tool Type as shown above. 
8. In the Tool Diameter section, select the drop-down arrow and choose Equal. 
9. Enter 1/8 as the diameter and press the Tab key or Enter to display the numeric value 

(0.125), 

10. Select the OK button  to exit Tool List Filter.  
11. Select the 1/8 Ball Endmill from the list. 
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12. Select the OK button  to exit the Tool Selection screen.  
13. Make changes to the Toolpath parameters tab as shown below. 

 
 
14. Select the Art Base Surface Toolpath Parameters tab and change the Cutting method to 

Spiral – Rectangular and the Stepover Percent to 10% as shown.  
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15. Check the Finishing and Inside-Out buttons as shown below.  

 
 

16. Select the OK button  to exit Machine Art Base Surface parameters.  
 Note it may take a few minutes to generate the toolpath. 
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TASK 13: 
BACKPLOT THE TOOLPATH 
 
 In this task you will use Mastercam’s Backplot function to view the path the tools take to cut 

this part.  
 Backplot will enable you to review the cutting motions and identify any problem areas when 

cutting the part.  
 When the toolpath is being backplotted Mastercam displays the current X, Y, and Z 

coordinates in the left side of the status bar at the lower left corner of the screen. 
 
1. Select the Isometric view from the view toolbar. 

 

2. Select the Fit to screen icon to fit the part to the screen . 

3. To select all the operations to backplot, click the Select All icon  circled below. 

 
 
 Another method to Select all the operations is to click on the Toolpath Group-1 in the Tool 

Manager as shown by the arrow above. 
 
4. The next step is to select the Backplot selected operations icon shown below. 

 
 
5. Before you backplot the toolpath, ensure that the two buttons shown below are activated. 

The option on the left will Display Tool and the option on the right will Display rapid 
moves. These buttons act like a toggle switch, pressed in activates the function. 
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6. Set the play speed on the Backplot controls midway along the speed bar as shown by the 
arrow below and then select the Play button. 

 
 

 
 
7. After reviewing the backplot of the toolpath using a .125” ball endmill select the OK button 

 to exit Backplot. 
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TASK14: 
VERIFY THE TOOLPATH 
 Mastercam's Verify utility allows you to use solid models to simulate the machining of a part 

and shows collisions, if any exist.  
 This allows you to identify and correct program errors before they reach the shop floor. 
 
1. In the Toolpath Manager select all the operations to verify by clicking the Select All icon. 

 
 
2. Select the Verify selected operations button circled below. 

 
 
3. Enable the Turbo button as shown below. 
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4. Adjust the Verify speed by moving the slider bar in the speed control bar. 

 
 
5. Select the Play button to verify the two toolpaths. 

 
 
6. The finished part should appear as shown in the following picture. 

 
 

7. Select the OK button  to exit Verify.  
 
TASK 15:  
SAVE THE UPDATED MCX FILE 
 
1. Select the Save icon from the toolbar. 
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TASK 16:  
POST AND CREATE THE CNC CODE FILE 

1. Ensure all the operations are selected by clicking the Select All icon  from the 
Toolpath Manager. 

 
 
2. Select the Post selected operations button from the Toolpath Manager. 
 Note: If you cannot see G1, click on the right pane of the Toolpath Manager and expand the 

pane to the right. 

 
 
3. In the Post processing dialog box, make the necessary changes as shown below. 

 
 
About Post Processing 
NC file:  
Select this option to save the NC file. The file name and extension are stored in the machine 
group properties for the selected operation. If you are posting operations from different machine 
groups or Mastercam files, or batch processing, Mastercam will create several files according to 
the settings for each machine group. 
 
Edit:  
When checked, automatically launches the default text editor with the file displayed so that you 
can review or modify it. 
 
4. Select the OK button  to continue. 
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5. Ensure the same name as your Mastercam part file name is displayed in the NC File name 
field as shown below. 

 

 

6. Select the OK button . 
7. The CNC code file opens in the default editor. The NC file displays in the white window. 

 
 
8. For instructions on how to Set Up and Run the CNC Machine refer to the Machine 

Instruction Lesson and follow the appropriate instructions for your CNC Machine.  

9. Select the  in the top right corner to exit the CNC editor. 
 
This completes Lesson-6 Art Organic. 
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TASK 17: 
REVIEW EXERCISE 
 
1. Use Mastercam to create the geometry and toolpaths for the Lesson-6-Exercise and follow 

the Exercise guidelines below: 
  

LESSON-6-EXERCISE GUIDELINES 
Steps Task Description 

Material Size 2 Create a rectangle 3” x 3” with X0, Y0 
at the lower left corner of the rectangle. 

Import Image 3 Import an image from the Classic 
Design Library that is different from the 
image used in this Lesson. 

Image Settings 3 Scale the image so it fits inside the 
rectangle leaving approximately 0.5” of 
space between the image and the 
rectangle. 

Create an Organic 
Surface 

7 Using the image create a number of 
organic surfaces. 

Add Texture 8 Add texture to an area of the image 
Stock Setup 11  
Cutters 12 1/8” Ball End Mill 
Feed rate 12 15 Inches per minute 
Spindle speed 12 4500 
Stepover Percent 12 10.00 precent 
Saved Mastercam File 15 Lesson-6-exerciseyourname.mcx 
Saved NC File 16 Lesson-6-exerciseyourname.nc 
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	Geometry Creation (CAD)
	Toolpath Creation (CAM)



